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Chapter 1 Introduction
ChromLab Software, User Management Edition enables ChromLab users to manage
access to their ChromLab projects.

When enabled, User Management Edition provides the necessary features to create user
and group accounts and to set permission levels on NGC systems as well as ChromLab
projects and subprojects and the data files within them.

In User Management Edition, the ChromLab administrator has the option to designate a
central computer as the host of a shared ChromLab database. Other ChromLab computers
and NGC systems that have access to the subnet on which the central computer resides
can access the shared database. In this environment, data can be shared among the
ChromLab computers and NGC systems.
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Chapter 1 Introduction

Finding Out More
After you install NGC Chromatography Systems and ChromLab Software documentation
from the NGC Chromatography Systems Software USB drive, you can access installed
NGC guides and tutorials on the Help menu in any ChromLab view.

More information about the NGC chromatography systems and ChromLab software is
available from the following sources.

n The NGC Chromatography Systems and ChromLab Software Installation Guide is
available on the NGC Chromatography Systems Software USB drive. This document
explains how to set up your environment, set up and install the NGC instrument in the
lab, and install ChromLab software and connect ChromLab to the NGC system.

n The NGC Chromatography Systems and ChromLab Software Instrument Guide is
available on the NGC Chromatography Systems Software USB drive. This document
details the modules that comprise the NGC instrument and includes information about
priming, plumbing, troubleshooting, and maintaining the NGC system.

n The NGC Chromatography Systems and ChromLab Software User Guide is available
on the NGC Chromatography Systems Software USB drive. This document explains
how to use ChromLab software to control the NGC instrument, run protein separations
and other operations manually, program methods to automate purification runs,
evaluate the results, and print experiment reports.

Note: Click the Bio-Rad logo in the upper right corner of any ChromLab window to
launch the Bio-Rad website.
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Chapter 2 Preparing to Share the ChromLab
Database

You can install ChromLab software on a central computer on your local network and share
data among multiple users, ChromLab computers, and NGC systems.

The following diagram illustrates supported shared ChromLab database configurations.
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Chapter 2 Preparing to Share the ChromLabDatabase
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In the shared environment, one installation of ChromLab software is designated as the host
of the shared database. The shared database can serve any of the following
configurations.

n Multiple ChromLab workstations

A ChromLab workstation has ChromLab Software, User Management Edition installed
but is not connected to an NGC system. From this computer you can create methods
and save them to the shared database. You can also access, view, and edit ChromLab
data files that are saved on the shared database.

n One NGC system connected to the central ChromLab computer

Data from the connected NGC system are saved to the shared database and are
accessible to users with the appropriate permission level from any computer running
ChromLab software.

n Multiple ChromLab computers and NGC systems

Computers running ChromLab software (known in this document as ChromLab
computers) and the NGC systems can access and use the shared database. Each
ChromLab computer can connect to any available NGC system on the network,
operate it, and save data to the shared database. Data from the NGC systems are also
saved to the shared database.

n Multiple ChromLab computers connected to one NGC system

Multiple ChromLab computers can simultaneously connect to the same NGC system.
Take control access to the NGC system is granted at the user and group level. A user
with Take Control access can log into any computer and take control of the system.
This is useful in the event that the controlling computer is locked or the user performing
a run is not available and there is an immediate need to stop the instrument. In this
environment, only one ChromLab computer can control an NGC system at a time. All
other NGC computers have View access to the system.

Note: View access applies only to users or groups connecting to an NGC system
through a ChromLab computer. Any user can take control of the NGC system
using the system’s touch screen. The touch screen is never in View mode.

User Guide | 11



Chapter 2 Preparing to Share the ChromLabDatabase

Preparing Your Site
Note: You can upgrade ChromLab software standard or User Management Edition
from version 3.x or higher to version 6.1. If you are running an earlier version of
ChromLab software, you must first upgrade to one of these versions before you can
upgrade to ChromLab 6.1.

Preparing your site to share a ChromLab database requires the following tasks:

1. Verify the site requirements for the central computer.

See the next section, Site Requirements.

2. Verify that the central computer meets the hardware and software requirements.

See System Requirements on page 13.

3. Install or upgrade ChromLab software on the central and remote computers.

For detailed instructions about installing or upgrading ChromLab software and
connecting to the NGC system, see the NGC Chromatography Systems and
ChromLab Software Installation Guide.

Site Requirements
The room and power requirements for installing NGC systems and ChromLab software in a
shared database environment are the same as those for local installations.

Note: Ensure that the network hosting the ChromLab computers and NGC systems
supports Internet Protocol version 4 (IPv4).

For specific information, see the chapter Preparing the ChromLab Computer in the NGC
Chromatography Systems and ChromLab Software Installation Guide.
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Preparing Your Site

System Requirements
The system requirements for the central ChromLab computer or server are very similar to
those for the local and remote installation of ChromLab with the differences bolded in this
table.

Hardware and Software Minimum Requirement

One of the following:

n Microsoft Windows 10 Pro (64-bit only)

n Microsoft Windows 10 Enterprise (64-bit only)

n Operating systemMicrosoft Windows Server 2012
R2

n Microsoft Windows Server 2016

Processor Intel Pentium IV with EM64T support or equivalent,
3.0 GHz minimum

RAM 8 GB

Hard disk space 500 GB minimum
Note: ChromLab installs Microsoft SQL Server 2014
Express. This application requires 6 GB of disk space.

File system NTFS (New Technology File System)

Optional peripherals
(Required only if an NGC
system is connected to the
central computer.)

USB 3.0 high speed ports (2 minimum)
Mouse

Keyboard

2 gigabit Ethernet port (1 minimum)

Important: Do not install User Management Edition on a Windows Server computer that
you plan to upgrade to, or that has, a newer version of Microsoft SQL Server installed.

Table 1. Minimum system requirements for a shared ChromLab database
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Chapter 3 Preparing the Central Computer
and NGC Systems

To ensure that the NGC systems can successfully connect to the central ChromLab
computer, they all must have access to the subnet on which the central computer resides.

Important: If an NGC system is connected by an ethernet communication cable to a
ChromLab computer that is not the central computer, disconnect the cable from the
ChromLab computer and connect the NGC system to the network. See the NGC
Chromatography Systems and ChromLab Software Installation Guide for information
about connecting your NGC system to the network. Ensure the network can access the
subnet on which the central computer resides.

Before setting up the shared database, determine which computer will host the shared
database. Choose a clean computer (one that does not have an existing installation of
ChromLab) to host the shared database.

Notes:

n Bio-Rad strongly suggests that you host the shared database on a dedicated computer
or server that is regularly backed up.

n Ensure that all remote computers and NGC systems have access to that computer.

n If installing on a Windows Server computer, ensure that it is dedicated to the
ChromLab installation. ChromLab requires and installs Microsoft SQL Server 2014
and is not supported on any other version of this software.
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Chapter 3 Preparing the CentralComputer and NGC Systems

Preparing the Central Computer and NGC Systems
Preparing the central computer and the NGC systems requires the following tasks. This
chapter explains these tasks in detail.

1. Install ChromLab software on the central computer and all remote computers and NGC
systems.

See NGC Chromatography Systems and ChromLab Software Installation Guide.

2. (Optional) Restore ChromLab data into the ChromLab database on the central
computer.

See Backing Up and Restoring ChromLab Data to the Central Computer on page 17.

3. Verify that all NGC systems and remote ChromLab computers can access the subnet
on which the central ChromLab computer will reside.

See your system or network administrator for information about subnets and setup.

4. Assign a static IP address to the central ChromLab computer.

See your system administrator for information about assigning a static IP address to
the central computer.

5. Verify or assign a unique system name to each NGC system.

See Verifying Each NGC System Name Is Unique on page 22.

6. Verify or assign a static IP address to each NGC system.

See Setting a Static IP Address on Each NGC System on page 20.

7. Verify that the central computer can access each NGC system.

See Verifying that All NGC Systems Can Reach the Central Computer on page 23.
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Preparing the CentralComputer and NGC Systems

Backing Up and Restoring ChromLab Data to the Central
Computer
Bio-Rad recommends that you activate ChromLab Software, User Management Edition on
a clean computer (one that does not have ChromLab installed). After you install ChromLab
software on the clean computer and upgrade your existing ChromLab databases to version
6.1, use ChromLab Administration to back up your largest database and restore it onto the
central computer. You can also use ChromLab Administration to set a reminder to back up
the NGC database on a daily, weekly, or monthly basis.

Important: Restoring backup data overwrites existing ChromLab data. Perform this
task only once, and carefully select the database to back up and restore.

Backing Up ChromLab Data on the Remote Computer

Perform the backup procedure on the remote ChromLab computer.

To back up a ChromLab database

1. Verify that you have upgraded ChromLab to version 6.1.

2. On the remote computer, determine the size of the NGC database.

a. Navigate to C:\ProgramData\Bio-Rad\NGC\Database.

b. Right-click on the Database folder and select Properties.

c. On the General tab, note the Size value.

Ensure that the disk on which you plan to save the backup zip file has free disk space
that is at least equal to the size of the NGC database.

3. On the Start menu, select ChromLab > ChromLab Administration and log into
ChromLab Administration.

4. In ChromLab Administration, select the Backup and Restore tab.

User Guide | 17



Chapter 3 Preparing the CentralComputer and NGC Systems

5. In the Backup section, click Browse to browse to a location into which to save the NGC
backup (.bak) file.

Note: Ensure that the central computer can access the target location.

6. Click Backup.

ChromLab displays a status bar of the backup progress. Depending on the size of your
database, the backup can take some time.

7. When the backup completes, close ChromLab Administration.

Setting a Backup Reminder on the Remote Computer

You can set a reminder to back up the central database. The reminder appears on the
ChromLab computer at the time interval you set. From the ChromLab Administration
Backup Reminder dialog box, you can open ChromLab Administration and perform the
backup.

Alternatively, you can close the reminder dialog box and perform the backup at another
time.

To set a reminder to back up the central database

1. Open ChromLab Administration and select the Backup and Restore tab.

2. In the Backup Reminder section, verify the Set Reminder checkbox is selected.

3. Use the up and down arrows to set the numeric interval for the reminder and select
either Daily, Weekly, or Monthly from the dropdown list.

4. Click Apply.

To stop receiving reminders to back up the database

u In the Backup Reminder section, clear the Set Reminder checkbox and click Apply.
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Preparing the CentralComputer and NGC Systems

Restoring ChromLab Data to the Central Computer

Important: Restoring backup data overwrites existing ChromLab data. Ensure the
central computer does not have existing ChromLab data.

Perform this task on the central ChromLab computer. Ensure the computer has free disk
space that is at least equal to the size of the backup file.

To restore ChromLab data to the central ChromLab computer

1. Verify that you have installed ChromLab 6.1 on the central computer.

2. On the Start menu, select ChromLab > ChromLab Administration.

3. In the Restore section, click Browse to browse to the location where you saved the
NGC backup (.bak) file.

4. Click Restore.

ChromLab displays a status bar of the restore progress. Depending on the size of your
database, the restore can take some time.

5. When the restore completes, close ChromLab Administration.
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Chapter 3 Preparing the CentralComputer and NGC Systems

Setting a Static IP Address on Each NGC System
Note: Bio-Rad strongly recommends that you set a static IP address on each NGC
system that connects to the central computer. Alternatively, you can record and use its
system name to verify its connection to the central computer.

Important: The NGC system must restart to apply the IP address changes.

To set a static IP address on the NGC system

1. On the instrument touch screen, select System Information on the dropdown menu.

The System Information dialog box appears.

2. In the General tab, click Configure beside System IP Address.

The Configure IP Address dialog box appears.

20 | ChromLab Software, User Management Edition



Preparing the CentralComputer and NGC Systems

3. In the Configure IP Address dialog box, select Use the following IP address and
provide the IP address, subnet mask, default gateway, and DNS server information
specific to your site.

Tip: See your system or network administrator for the appropriate IP settings.

n IP address — the specific numeric address for the NGC system.

n Subnet mask — the numeric filter used to define the subnet to which the IP
address belongs.

n Default gateway — (required only if you plan to install the shared ChromLab
database on a separate subnet or access the NGC system from ChromLab
computers that are on another subnet) this is the IP address of the node that
allows communication between the subnets.

n DNS Server — the IP address of the node that translates a server name to its IP
address.

4. Click OK.

A message appears explaining that the NGC system must restart.

5. Click Yes to save the changes and restart the system.

The NGC system shuts down and restarts.

6. To verify that the IP address changed successfully, open the System Information dialog
box from the dropdown menu and view System IP Address in the General tab.
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Chapter 3 Preparing the CentralComputer and NGC Systems

Verifying Each NGC System Name Is Unique
Each NGC system that connects to the central ChromLab computer must have a unique
system name. Locate the NGC system’s name and, if necessary, change the name so that
it is unique.

To locate the NGC system name

1. On the instrument touch screen, select System Information on the dropdown menu.

The System Information dialog box appears displaying the General tab.

2. Locate and record the system name and system IP address information in the General
tab.

3. Close the System Information dialog box.

If two or more NGC systems have the same name, you must change one name so that
each is unique.

To change the NGC system name

1. On the instrument touch screen, select System Settings on the dropdown menu.

The System Settings dialog box appears.

2. Select the System Name tab.

3. On the System Name tab, type a new name for the system and click OK to save the
change and close the System Settings dialog box.

4. To verify that the name changed successfully, open the System Information dialog box
from the dropdown menu and view System Name in the General tab.
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Preparing the CentralComputer and NGC Systems

Verifying that All NGC Systems Can Reach the Central
Computer
To verify that all NGC systems can reach the central computer

1. On the central ChromLab computer, open a command prompt window.

2. At the prompt, type

> ping <NGC_IP_address>

If the NGC systm can reach the central computer, a response similar to the following
appears:

Pinging <NGC_system_name>

Reply from <data from local IP Address> time<1ms

3. Perform Step 2 for each NGC system and remote computer you plan to connect to the
central computer.

4. Exit the command prompt window.

Important: If you experience a problem accessing an NGC system from the central
computer, contact your system or network administrator and verify the network
configuration, routing, firewall, and antivirus settings are correct. See Appendix A,
Troubleshooting Shared Database Connection Issues for more information.
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Chapter 4 Activating User Management
Edition on the Central Computer

When ChromLab is installed, by default it is set to run in standard mode (that is, only the
local database is available). It continues to run in this mode until a user with ChromLab
Administrator privileges activates ChromLab Software, User Management Edition.

The workflow for activating User Management Edition on the central computer consists of
the following tasks. This chapter explains these tasks in detail.

1. Create an NGC database backup folder on the central computer.

See Creating an NGC Database Backup Folder on page 39.

2. Change the default admin password in ChromLab Administration.

See Changing the ChromLab Default Password on page 41.

3. Activate User Management Edition on the central computer.

See Activating User Management Edition on the Central Computer on page 29.

4. Create ChromLab users and groups on the central computer and assign access levels
to NGC systems.

See Next Steps on page 33.

Important: In order to use ChromLab after User Management Edition has been
activated on the remote computers, users must log in to the shared database. This
requires each user to have a valid user name and password. You must create users
after you activate User Management Edition on the central computer. For more
information, see Chapter 7, Managing ChromLab Users and Groups in User
Management Edition.
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Chapter 4 Activating User Management Edition on the CentralComputer

Creating an NGC Database Backup Folder
ChromLab automatically backs up the existing NGC database when you activate User
Management Edition. If you have not previously backed up your NGC database, consider
creating the database backup folder at this time.

Note: Even if you are installing ChromLab for the first time, the system backs up the
empty NGC database. A new, empty NGC database requires approximately 75 MB of
free disk space.

Perform this task on all computers on which you plan to activate User Management Edition.

To create the NGC database backup folder

1. Determine the size of the NGC database.

a. Navigate to C:\ProgramData\Bio-Rad\NGC\Database.

b. Right-click the Database folder and select Properties.

c. On the General tab, note the Size value.

Ensure that the disk on which you plan to save the backup zip file (the target disk) has
free disk space that is at least equal to the size of the NGC database.

2. On the backup computer, right-click the target folder and select New > Folder.

3. Rename the new folder, for example, NGC Database Backup.
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Changing the ChromLabDefault Password

Changing the ChromLab Default Password
You activate User Management Edition through the ChromLab Administration tool. The first
time you launch ChromLab Administration on each computer you must change the default
admin password before continuing.

Note: You cannot activate User Management Edition while either ChromLab software
or the NGC system is in use. Close ChromLab and shut down the system before
launching ChromLab Administration.

Important: You will perform this task on each remote ChromLab computer as well as
the central ChromLab computer. Ensure that the Administrator password for each
ChromLab computer is unique. Keep the Administrator passwords for all ChromLab
computers in a secure place.

To change the default admin password

1. On the Start menu, select ChromLab > ChromLab Administration.

The Login dialog box appears.

2. Type the word admin for both the user name and password and click Login.
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Chapter 4 Activating User Management Edition on the CentralComputer

The Change Password dialog box appears.

3. Type a new password for the ChromLab administrator in the Password field, type it
again in the Confirm Password field, and click Change.
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Activating User Management Edition on the CentralComputer

Activating User Management Edition on the Central
Computer

Note: You cannot activate User Management Edition while either ChromLab or the
NGC system are in use. Close ChromLab and shut down the system before launching
ChromLab Administration.

Activating User Management Edition requires a license key. This key is located on the back
of your User Management Edition installation package.

When you activate User Management Edition, the system prompts you to select a database
location. This section explains how to activate User Management Edition on the central
computer and designate its database as the shared database.

Important: ChromLab automatically backs up the current NGC database, creates an
empty database, and then activates User Management Edition. Depending on the size
of your current NGC database, this process can take some time.

To activate User Management Edition on the central computer

1. On the Start menu, select ChromLab > ChromLab Administration and log in as the
ChromLab administrator.
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Chapter 4 Activating User Management Edition on the CentralComputer

ChromLab Administration opens, displaying the Licensing tab.

2. Select ChromLab User Management Edition from the Select mode to activate
dropdown list.

3. In the License Key field, type the 18-character User Management Edition license key
and click Apply.

The Activating ChromLab User Management Edition dialog box appears.

4. Click OK. The Browse For Folder dialog appears.

5. In the Browse For Folder dialog box, select the NGC backup folder that you created
and click OK to create and save the NGC backup (.ubk) file.
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Activating User Management Edition on the CentralComputer

When the backup completes, the Select Database Location dialog box appears.

6. In the Select Database Location dialog box, select Designate this computer as the
shared database host.

7. (Optional) Click Test Connection.

8. Click Activate User Management Edition to establish the shared database on this
computer.

A message informs you that changing the database to sharing mode requires
ChromLab to shut down. ChromLab connects to the shared database when you restart
the application.

9. Click Yes to continue the connection process.
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Chapter 4 Activating User Management Edition on the CentralComputer

ChromLab Administration closes. The next time it is started, ChromLab connects to the
shared database on this computer.
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Next Steps

Next Steps
After you activate User Management Edition on the central computer and before you
connect the remote computers to the shared database, Bio-Rad recommends that you
create users and groups and assign access levels to the NGC systems. Afterwards you can
uninstall ChromLab software from the central computer.

Creating Users and Groups
Important: In order to use ChromLab after User Management Edition has been
activated on the remote computers, users must log in to the shared database. This
requires each user to have a valid user name and password. If you have not yet done
so, Bio-Rad suggests that you create users before activating User Management
Edition on the remote computers.

For more information about creating and managing ChromLab user and group accounts,
see Chapter 7, Managing ChromLab Users and Groups in User Management Edition.

Assigning Access Levels on NGC Systems
Important: Because this affects the user’s ability to access NGC systems, perform this
task on the central computer after you create user and group accounts and before you
connect remote computers to it.

In User Management Edition, multiple ChromLab computers can simultaneously connect to
the same NGC system. Access to the NGC system is granted at the user and group level.

User Management Edition provides three access levels to the NGC systems. Access levels
determine the user’s access rights to the NGC system.

For more information about assigning access levels to users and groups on NGC systems,
see Chapter 9, Connecting Multiple ChromLab Computers to One NGC System.
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Chapter 4 Activating User Management Edition on the CentralComputer

Uninstalling ChromLab Software on the Central Computer
Note: This task is optional.

After you activate User Management Edition on the central computer, and have created
users and groups and assigned access levels to them, you can uninstall ChromLab
software from the central computer. Although uninstalling removes ChromLab software and
ChromLab Administration from the computer, the ChromLab database remains and remote
ChromLab computers and NGC systems can access it.

Special Considerations

Uninstalling ChromLab from the central computer removes the Bio-Rad firewall settings
and the backup and restore feature in ChromLab Administration. This section lists two
important considerations to keep in mind if you choose to uninstall ChromLab software
from the central computer.

Creating Inbound Firewall Rules for the ChromLab Database

You must create the following custom inbound firewall rules in order for the SQL Browser
and SQL Server services to receive data from the network:

n Bio-Rad NGC SQLServer NG

n Bio-Rad NGC SQLServer Browser

Important: Contact your system or network administrator or Bio-Rad Technical
Support for assistance. See Manually Adding Inbound Firewall Rules on page 105 for
more information.
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Next Steps

Backing Up and Restoring ChromLab Data

You will not be able to use ChromLab Administration to back up and restore the NGC
database. You must use SQL Server Management Studio or a 3rd party tool to back up and
restore the database. You require the password for the sa user to connect to the NGC
instance and perform this task.

For more information, contact Bio-Rad Technical Support.

Tip: You can also reinstall the same version of ChromLab software on the central
computer at any time to access ChromLab Administration and perform backup and
restore functions.
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Chapter 5 Connecting Remote Computers to
the Central Computer

When ChromLab is installed, by default it is set to run in standard mode (that is, only the
local database is available). It continues to run in this mode until a user with ChromLab
Administrator privileges activates ChromLab Software, User Management Edition.

The workflow for connecting remote ChromLab computers to the shared database consists
of the following tasks. This chapter explains these tasks in detail.

1. Verify that ChromLab 6.1 is installed on each remote computer.

2. (Optional but recommended) Export existing 6.1 ChromLab data from all computers.

3. Verify date and location settings on the remote computers.

See Locating the Date and Time Settings on ChromLab Computers on page 38.

4. Create an NGC database backup folder on all remote ChromLab computers.

See Creating an NGC Database Backup Folder on page 39.

5. Change the local default admin password in ChromLab Administration.

See Changing the ChromLab Default Password on page 41.

6. Activate User Management Edition on each remote computer.

See Activating ChromLab Software User Management Edition on Remote Computers
on page 43.

7. (Optional) Import existing data to the shared database.
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Chapter 5 Connecting Remote Computers to the CentralComputer

Important: In order to use ChromLab after User Management Edition has been
activated on the remote computers, users must log in to the shared database. This
requires each user to have a valid user name and password. If you have not yet done
so, Bio-Rad suggests that you create users at this time. For more information about
creating and managing ChromLab user and group accounts, see Chapter 7,
Managing ChromLab Users and Groups in User Management Edition.

Locating the Date and Time Settings on ChromLab
Computers

In order for ChromLab to function correctly, the date and time settings on remote computers
must be the same as those on the central computer.

Perform this task on the central ChromLab computer first. Verify that the settings on the
remote computers are the same as those on the central computer.

To locate the date and time settings

1. On the central ChromLab computer, open the Control Panel and select Date and Time.

2. In the Date and Time dialog box, note the current date, time, and time zone settings.

3. Close the Date and Time dialog box on the central computer.

4. On each remote computer, open the Date and Time dialog box.

5. Note the date, time, and time zone settings.

n If the time zone is different from that on the central computer, click Change time
zone and modify the settings as necessary.

n If the date or time differ from those on the central computer, click Change date and
time and modify the settings as necessary.

6. Close the Date and Time dialog box.
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Creating an NGCDatabase Backup Folder

Creating an NGC Database Backup Folder
ChromLab automatically backs up the existing NGC database when you activate User
Management Edition. If you have not previously backed up your NGC database, consider
creating the database backup folder at this time.

Note: Even if you are installing ChromLab for the first time, the system backs up the
empty NGC database. A new, empty NGC database requires approximately 75 MB of
free disk space.

Perform this task on all computers on which you plan to activate User Management Edition.

To create the NGC database backup folder

1. Determine the size of the NGC database.

a. Navigate to C:\ProgramData\Bio-Rad\NGC\Database.

b. Right-click the Database folder and select Properties.

c. On the General tab, note the Size value.

Ensure that the disk on which you plan to save the backup zip file (the target disk) has
free disk space that is at least equal to the size of the NGC database.

2. On the backup computer, right-click the target folder and select New > Folder.

3. Rename the new folder, for example, NGC Database Backup.
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Exporting Existing ChromLab Data
Important: ChromLab creates a backup of the database that resides on the local
computer when you activate User Management Edition. Because restoring the backup
data overwrites existing data, Bio-Rad strongly recommends that you export
ChromLab data from the local ChromLab database that you want to use in the shared
environment. Perform this procedure after you upgrade to ChromLab 6.1 and before
you activate User Management Edition on remote computers. You can then import the
data into the shared database after you set up the shared environment. This ensures
you have access to all your necessary data files.

For more information about exporting and importing ChromLab data, see the NGC
Chromatography Systems and ChromLab Software User Guide.

To export ChromLab data

1. Start ChromLab.

2. Select File > Browse to open the Browse Data dialog box.

3. Choose Methods on the View by dropdown list.

4. Select the project that contains the target file in the Projects pane.

5. Right-click the file or files to export in the right pane and select Export <file_type>.

The Browse for Folder dialog box appears.

6. Browse to a target folder or create a destination folder and click OK.

The Exporting NGC Files dialog box appears, showing the status of the export. When
the export is complete, Completed appears in the Status column.

7. Click OK to close the dialog box.
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Changing the ChromLab Default Password
You activate User Management Edition through the ChromLab Administration tool. The first
time you launch ChromLab Administration on each computer you must change the default
admin password before continuing.

Note: You cannot activate User Management Edition while either ChromLab software
or the NGC system is in use. Close ChromLab and shut down the system before
launching ChromLab Administration.

Important: You will perform this task on each remote ChromLab computer as well as
the central ChromLab computer. Ensure that the Administrator password for each
ChromLab computer is unique. Keep the Administrator passwords for all ChromLab
computers in a secure place.

To change the default admin password

1. On the Start menu, select ChromLab > ChromLab Administration.

The Login dialog box appears.

2. Type the word admin for both the user name and password and click Login.
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The Change Password dialog box appears.

3. Type a new password for the ChromLab administrator in the Password field, type it
again in the Confirm Password field, and click Change.
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Activating ChromLab Software User Management
Edition on Remote Computers

Note: You cannot activate User Management Edition while either ChromLab software
or the NGC system are in use. Close ChromLab and shut down the NGC system
before launching ChromLab Administration.

Perform this task on all remote computers that will access the shared database. This
includes

n ChromLab workstations

n ChromLab computers connected to NGC systems, including those in read-only mode

Important: ChromLab automatically backs up the current NGC database, creates an
empty database, and then activates User Management Edition. Depending on the size
of your current NGC database, this process can take some time.

To activate User Management Edition on remote computers

1. On the Start menu, select ChromLab > ChromLab Administration and log in as the
ChromLab administrator.
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ChromLab Administration opens, displaying the Licensing tab.

2. Select ChromLab User Management Edition from the Select mode to activate
dropdown list.

3. In the License Key field, type the 18-character ChromLab User Management Edition
license key and click Apply.

The Activating ChromLab User Management Edition dialog box appears.

4. Click OK. The Browse For Folder dialog appears.

5. In the Browse For Folder dialog box, select the NGC backup folder that you created
and click OK to create and save the NGC backup (.ubk) file.
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When the backup completes, the Select Database Location dialog box appears.

6. In the Select Database Location dialog box, select Remote shared database.

Tip: Select Local database only if you want to save data to the local ChromLab
database.

7. If it does not automatically appear, select the name or IP address of the central
computer in the dropdown list. Alternatively, type the central computer’s name or IP
address in the dropdown list box.

Important: You must use the same connection parameter for all remote
computers that will access the shared database. That is, all remote computers
should connect to the central computer using either its IP address or its computer

User Guide | 45



Chapter 5 Connecting Remote Computers to the CentralComputer

name. Bio-Rad strongly recommends that you connect to the central computer
using a static IP address.

8. (Optional) Click Test Connection.

9. Click Activate User Management Edition to connect to the shared database.

A message informs you that changing the database to sharing mode requires
ChromLab to shut down. ChromLab connects to the shared database when you restart
the application.

10. Click Yes to continue the connection process.

ChromLab Administration closes. The next time it is started, ChromLab connects to the
shared database on the central computer.

Importing Existing ChromLab Data
To ensure that you can access your current data after you set up the shared database and
connect to it from the remote computers, import the data from all remote computers into the
shared database.

Important: Until the ChromLab administrator has created users on the central
ChromLab computer, you will not be able to log in to ChromLab. Ensure that you have
a valid user name and password before performing this task.

To import ChromLab data

1. Start ChromLab and log in as a ChromLab user.

2. Select File > Import and choose NGC File.

The Import NGC File dialog box appears.

3. Click Select.

The Select Project dialog box appears.
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4. In the Select Project dialog box, do one of the following:

n Choose a destination project for the method or run and click Select Project.

n Create a new project and click Select Project.

n Right-click on an existing project and select New Project to create a subproject
and then click Select Project.

5. In the Import NGC File dialog box, click Browse to display the Open dialog box.

6. Select the file or files to import and click Open.

7. (Optional) In the Name box, type another name for the file.

Note: This option is available only when you select a file to import.

8. (Optional) Select Open on Import to open in the Evaluation window upon import.

Note: This option is available only when you select a single file to import.

9. Click Import. During the import a status dialog box appears. When all files have
successfully imported, the status displays Completed.

10. Click OK to close the dialog box.

The files are imported into the project you selected. Imported data files appear listed in
the Open Run and Open Analysis dialog boxes available on the File menu in the
Evaluation and Home windows.

For more information about exporting and importing ChromLab data, see the NGC
Chromatography Systems and ChromLab Software User Guide.
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Rules for Sharing ChromLab Data
Once the remote computers are connected to the shared database, users can create and
modify methods, run methods, and analyze runs. To ensure data integrity, ChromLab
enforces the rules noted in Table 2.

Tip: Remote users can log in to an NGC system while another user’s run is in
progress. However, only users with Take Control access can control an NGC system
that is in use by another user. Users with View access must wait until the run
completes before they can control the NGC system. As well, the run queue must be
cleared of pending runs before users with View access can control the NGC system.
For more information about controlling the NGC system, see Chapter 9, Connecting
Multiple ChromLab Computers to One NGC System.

Action Rule

Methods

Add a method to a project that contains another method
with the same name

Users are prompted to save the
method with a unique name before
saving it to the project.

Edit and save the same method at the same time
(parallel editing)

Changes made by the first user are
saved. The next user is prompted to
do one:

n Refresh the method then save

n Save the method with another
name

n Cancel and discard the changes

Edit and save the same method at different times
(sequential editing)

Changes made by all users are
saved.

Table 2. Rules for sharing ChromLab data
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Action Rule

Edit a method that was recently deleted by another user The original method is deleted. The
next user is prompted to do one:

n Save the method with another
name

n Cancel and discard the changes

Run the same method on different systems at the same
time

The method is queued and run in
parallel.

Method Templates

Add a method template to the database if another
template with the same name exists

Users are prompted to save the
template with a unique name before
saving.

Edit and save the same template at the same time
(parallel editing)

Changes made by the first user are
saved. The next user is prompted to
do one:

n Refresh the template then save

n Save the template with another
name

n Cancel and discard the changes

Edit and save the same template at different times
(sequential editing)

Changes made by all users are
saved.

Table 2. Rules for sharing ChromLab data, continued
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Action Rule

Edit a template that was recently deleted by another
user

The original template is deleted.
The next user is prompted to do
one:

n Save the method with another
name

n Cancel and discard the changes

Runs

Save a run to the database if another run with the same
name exists

Users are prompted to save the run
with a unique name before saving it
to the project.

Edit the same run at the same time (parallel editing) Changes made by the first user are
saved. The next user is informed
the run was changed and the run is
reloaded with the changes made.

Edit and save the same run at different times
(sequential editing)

Changes made by all users are
saved.

Edit a run that was recently deleted by another user The run is deleted. The next user is
informed the run was deleted and
the window closes.

Analyses

Save an analysis to the database if another analysis
with the same name exists

Users are prompted to save the
analysis with a unique name before
saving it to the project.

Table 2. Rules for sharing ChromLab data, continued
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Action Rule

Edit and save the same analysis at the same time
(parallel editing)

Changes made by the first user are
saved. The next user is prompted to
do one:

n Save the analysis with another
name

n Cancel and discard the changes

Edit and save the same analysis at different times
(sequential editing)

Changes made by all users are
saved.

Delete an analysis if another user has it open The original analysis is deleted.
The next user is prompted to do
one:

n Save the analysis with another
name

n Cancel and discard the changes

Fluidic Schemes

Delete a fluidic scheme that was used in a method run
by another user

The user is informed that the fluidic
scheme is in use and cannot be
deleted.

Select or delete a fluidic scheme that was recently
deleted by another user

Create a new fluidic scheme based on a scheme that
was recently deleted by another user

The original fluidic scheme is
deleted. The next user is prompted
to do one:

n Save the fluidic scheme with
another name

n Cancel and discard the changes

Table 2. Rules for sharing ChromLab data, continued
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Workspace

ChromLab Software, User Management Edition is a licensed version of ChromLab
software. When enabled, User Management Edition provides an intuitive interface
enabling users to manage access to their ChromLab projects.

ChromLab software presents four primary workspaces.

n The Home window

n The System Control window

n The Method Editor window

n The Evaluation window

Each workspace and the NGC instrument touch screen are shown and described in detail
in the NGC Chromatography Systems and ChromLab Software User Guide.

In User Management Edition, you use ChromLab Administration to

n Activate ChromLab User Management Edition

n Create and maintain user groups

n Create and maintain user accounts

n Change the ChromLab database location

n Back up and restore the ChromLab database

ChromLab Administration and the ChromLab Home window are shown and described in
this chapter.
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ChromLab Administration
When ChromLab Administration is launched after User Management Edition is activated, it
opens displaying the User Administration tab. The application also displays the Licensing,
Backup and Restore, and Database Location tabs.

The Licensing, Database Location, and Backup and Restore tabs are available to users
with the Administrator role. The User Administration tab is available to all users.

Menu Commands
Each tab has the same menu commands. This section explains the menu commands for
ChromLab Administration.
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File Menu Command

Close— closes ChromLab Administration.

View Menu Commands

Show Inactive Users— displays currently active and deactivated User Management
Edition users.

Note: This option is enabled only on the User Administration tab.

Password Options— displays the Password Options dialog box. See Setting Password
Options on page 64 for more information.

Note: This option is enabled only for users with the Administrator role.

Help Menu Command

About— displays ChromLab Administration copyright and version information.
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The User Management Edition Home Window
ChromLab Software, User Management Edition opens with the Home window, which
displays three panes and the System Control tab.

When User Management Edition is activated, a lock and the user name of the logged in
user appear in the left corner of the status bar. The database location and NGC instrument
name appear in the right corner. Links to files that the logged in user recently accessed
appear listed at the bottom of the window.

56 | ChromLab Software, User Management Edition



Chapter 7 Managing ChromLab Users and
Groups in User Management Edition

To access the features in ChromLab Software, User Management Edition, each user must
have a user account on the ChromLab computer. Each user can also be assigned to one
or more ChromLab groups, although it is not necessary to create groups in order for users
to access the features in User Management Edition.

Important: The user account admin is the default Administrator account, which you
use to initially log in to ChromLab Administration. It is recommended that you create a
specific user to administer User Management Edition. Assign this user the
Administrator account and perform all administration tasks with this user. Do not use
the admin user account to perform activities other than to log in and create this first
user.

Note: If you have not yet done so, you must activate User Management Edition. See
Activating User Management Edition on the Central Computer on page 29 before
continuing.
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Managing ChromLab Users
ChromLab user accounts can have any name or password. See Setting Password Options
on page 64 for information about setting password rules.

Adding User Accounts
Important: Add users to the primary ChromLab database. In a shared database
environment, add users after connecting to the shared database on the central
computer. In a standard environment, add users after connecting to the local database.
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To add user accounts to ChromLab

1. On the Start menu, select ChromLab > ChromLab Administration and log in as a
ChromLab administrator. ChromLab Administration opens, displaying the User
Administration tab.

2. Click Add User. The Add User dialog box appears.
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3. Enter identifying information about the user in the text boxes.

Note: Information provided in the first name, last name, and username boxes
cannot include the following characters:

" / \ [  ] : ; | = , + * ? < >

n First name— required.

n Last name— required.

n Username— required. The username must be unique.

n Password— required. The initial password can be generic. Encourage users to
change their passwords after they first log in. See Setting Password Options on
page 64 for more information.
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n Groups— required. All active users are members of the default Users group.
Click Set Groups to add the user to additional groups.

Tip: You can add the user to one or more groups at a later date. See Editing a
User Account on page 61 or Adding Users to a Group on page 72 for more
information.

n Email address

n Phone number

n Location

n Active— by default, all user accounts are active when first created. Clear this
checkbox to remove a user’s access to ChromLab.

n Administrator— by default, user accounts are not assigned the administrator role
when first created. Select this checkbox to assign this role to the user.

4. Do one of the following:

n Click OK. The user account is added to the ChromLab database.

n Click Cancel to close the Add User dialog box without saving the user account to
the ChromLab database.

5. Create additional user accounts for each ChromLab user at your site.

6. Close ChromLab Administration.

Editing a User Account
To edit a user account

1. On the Start menu, select ChromLab > ChromLab Administration and log in as a
ChromLab administrator.

2. From the list of user accounts in the left pane in the User Administration dialog box,
select the user account to modify.
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3. Click Edit User.

The Edit User dialog box appears.

4. Do one of the following:

n Make the required changes to the account and click OK.

n Click Cancel to close the Edit User dialog box without saving the changes.

Note: If you clear the Active checkbox to deactivate a current user account, the
following message appears:
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5. Click Yes to continue or No to cancel the action and close the dialog box.

6. Close ChromLab Administration.

Deleting a User Account
Note: You can delete only user accounts for which no data files are stored in the User
Management Edition database. That is, you cannot delete user accounts that created
or modified methods, runs, or analyses. However, you can deactivate these accounts.
See Editing a User Account on page 61 for more information.

To delete a user account

1. On the Start menu, select ChromLab > ChromLab Administration and log in as a
ChromLab administrator.

2. From the list of user accounts in the User Administration dialog box, select the user
account to delete.

3. Click Delete User. A message similar to the following appears.

4. Click Yes to continue or No to cancel the action.

5. Close ChromLab Administration.
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Setting Password Options
In User Management Edition, ChromLab administrators can set password options.

To set password options

1. On the Start menu, select ChromLab > ChromLab Administration and log in as a
ChromLab administrator.

2. Select View > Password Options. The Password Options dialog box appears.

3. Select the checkbox to enable the password option.

n Require upper case— the password requires at least one upper case letter.

n Require special characters— the password requires at least one of the
following characters:
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!
@
%
&
*
(
)
{
}
. (dot)

[
]
\
?
/
:
;
_ (underscore)
- (hyphen)

n Require numerals— the password requires at least one numeral
(0–9).

n Require at least # characters— the password requires at least the specified
number of characters.

The default is five characters. You can increase or decrease the value.

n Change password every # months— the password must be changed at least
once every specified number of months.

n Do not allow previously used # passwords—ChromLab stores the specified
number of passwords for the user account and prohibits their reuse.

n Maximum failed login attempts— the user can try the specified number of times
to log in to the account with this password.

The default is ten attempts. You can increase or decrease the value.

Note: If the user fails to successfully log in within the specified number of
attempts, the account is locked. A message informs the user to contact the
ChromLab administrator to reset the password.

4. Select or clear the option checkboxes as appropriate.

The system enforces the selected password options.

5. Click OK to save the password settings and close the dialog box.
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Managing ChromLab Groups
ChromLab Administration includes two default groups: Administrators and Users.
ChromLab Administration adds the default user admin to the Administrators group. You
cannot remove this user from the Administrators group, and this user cannot be added to
any other group. However, you can add or remove other user accounts to the
Administrators group as necessary. All users added to this group are automatically
assigned the Administrator account. Only users assigned the Administrator account can
create, edit, and delete ChromLab users and groups.

By default, ChromLab Administration adds all created user accounts to the general Users
group. Users can be members of multiple groups, including the Administrators group.

Adding a Group
Important: Add user groups to the primary ChromLab database. In a shared database
environment, add groups after connecting to the shared database on the central
computer. In a standard environment, add groups after connecting to the local
database.
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To add a group to ChromLab

1. On the Start menu, select ChromLab > ChromLab Administration and log in as a
ChromLab administrator. ChromLab Administration opens, displaying the Users dialog
box in the User Administration tab.
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2. Click Groups in the left pane to display the Groups list box.

The two default groups, Administrators and Users, appear in the Groups pane.

3. Click Add Group. The Add Group dialog box appears.
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4. Type a name for the group and an optional description.

Tip: The Name field is limited to 50 characters. The Description field has no
character limit. You can enter any special character, numerals, and line breaks in
this field.

5. If you previously added users to ChromLab, their user names appear in the Group
Members box.

Select the users you want to add to the group, or click Select All to add all users to the
group.

6. Do one of the following:

n Click OK. The group is added to the ChromLab database.

n Click Cancel to close the Add Group dialog box without saving the group to the
ChromLab database.

7. Close ChromLab Administration.
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Editing a Group
You can change a group’s name or its description. You can also add members to or
remove members from the group if you have already created users.

To edit a group

1. On the Start menu, select ChromLab > ChromLab Administration and log in as a
ChromLab administrator.

2. In the User Administration tab, click Groups to display the available groups.

3. From the list of groups, select the target group and click Edit Group.

The Edit Group dialog box appears.

4. (Optional) Change the name or description of the group.
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5. In the Group Members section, do any of the following:

n Select users to add to the group.

n Clear the users to remove from the group.

n Click Select All to add all users to or remove all users from the group.

6. Do one of the following:

n Click OK to save the changes and close the Edit Group dialog box.

n Click Cancel to close the Edit Group dialog box without saving the changes.

7. Close ChromLab Administration.
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Adding Users to a Group
This section assumes that you have created user accounts and plan to add multiple users
to a group. If you are creating new user accounts, you can add the user to an existing
group at that time. See Adding User Accounts on page 58 for more information.

You can also modify an existing user account and add it to a group. See Editing a User
Account on page 61 for more information.

To add users to a group

1. On the Start menu, select ChromLab > ChromLab Administration and log in as a
ChromLab administrator.

2. In the User Administration tab, click Groups to display the available groups.

3. From the list of groups, select the target group and click Edit Group. The Edit Group
selection box appears.

4. In the Group Members section, select the users to add to the group.

Alternatively, click Select All to select all available users and add them to the group.

5. Click OK. The user names appear in the Group Members list for the target group.
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6. Close ChromLab Administration.

Removing Users from a Group
To remove users from a group

1. On the Start menu, select ChromLab > ChromLab Administration and log in as a
ChromLab administrator.

2. In the User Administration tab, click Groups to display the available groups.

3. From the list of groups, select the target group and click Edit Group. The Edit Group
dialog box appears.

4. In the Group Members section, clear the checkboxes of the users to remove from the
group.

Alternatively, clear Select All to remove all users from the group.

5. Click OK and close ChromLab Administration.

Deleting a Group
Note: Deleting a group removes it from the list of available groups. Deleting a group
does not delete the user accounts from the ChromLab database.

To delete to a group

1. On the Start menu, select ChromLab > ChromLab Administration and log in as a
ChromLab administrator.

2. In the User Administration tab, click Groups to display the available groups.

3. Select the target group and click Delete Group.
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A message similar to the following appears.

4. Click Yes to continue or No to cancel the action.

5. Close ChromLab Administration.
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Starting ChromLab Software User Management Edition
To start ChromLab Software, User Management Edition, each user must log in with a valid
username and password.

To start User Management Edition

1. Click the ChromLab icon to start the application.

2. In the Login dialog box, enter your username and password.

3. Click Login.
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ChromLab Software, User Management Edition has three permission levels:

n Read — identified in the Browse Data dialog box by small eyeglasses beside the
project

n Read/Write — identified by a small pencil beside the project

n Full Control — identified by a small person beside the project

Permission levels determine the user's access rights to the objects within the project (that
is, the methods, runs, and analyses).

While the ChromLab administrator creates and manages the users and groups, the project
owner (the user who creates the project) grants permissions on projects. Users and groups
are granted one permission level per project. However, the users and groups can have
different permission levels on each project to which they have access. For example, a user
can be assigned Read access on Project A, Read/Write access on Project B, and Full
Control access on Project C.

Permission levels can also be applied to subprojects. By default, a user’s permission on a
subproject is inherited from the permission set on the parent project. If the user belongs to
a group, the user’s permission level is inherited from the group. If the user belongs to
multiple groups, all of which have different permission levels on the project, the user
inherits the highest level permission.

For example, user EBrizel belongs to the groups Users, Location_ChAZ, and Location_SR.
The group Users has Read permission on project TNavarro, the group Location_ChAZ has
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Read/Write permission, and the group Location_SR has Full Control. As a member of all
groups, user EBrizel has Full Control on TNavarro and its subprojects.

The owner of the project TNavarro can limit user EBrizel’s permission level on the parent or
any subproject as necessary.
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Permission Levels
Table 3 on page 80 lists the ChromLab User Management Edition permission levels and
the related access rights per object.
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Permission
Level Methods Runs Analyses

Read Users with read
permissions can
n Open and view
methods

n Edit and save the
method with a new
name into a project
on which the user
has Read/Write or
Full Control
permissions

n Run methods

n Export methods

Users with read
permissions cannot
n Save methods

n Import methods

n Move methods to
another project

n Rename methods

n Delete methods

Users with read
permissions can
n Open and view runs

n View and change
attributes (for
example, trace
colors and scales)

n Export runs

Users with read
permissions cannot
n Import runs

n Edit runs

n Analyze runs

n Open two or more
runs for trace
comparison

n Add or delete
attachments from
runs

n Move runs to
another project

n Rename runs

n Delete runs

Users with read
permissions can
n Create analyses and
trace comparisons

n Open and view
existing analyses

n View and change
attributes (for
example, trace
colors and scales)

Users with read
permissions cannot
n Edit existing
analyses

n Copy analyses

n Rename analyses

n Delete analyses

Table 3. Permission levels and access rights
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Permission
Level Methods Runs Analyses

Read/Write In addition to Read
permissions, users
with read/write
permissions can
n Edit methods and
save them to the
same project

n Rename methods

n Import methods

Users with
read/write
permissions cannot
n Move methods to
another project

n Delete methods

In addition to Read
permissions, users
with read/write
permissions can
n Edit runs

n Analyze runs

n Rename runs

n Import runs

Users with
read/write
permissions cannot
n Move runs to
another project

n Delete runs

In addition to Read
permissions, users
with read/write
permissions can
n Edit analyses

n Copy analyses

n Rename analyses

Users with
read/write
permissions cannot
n Delete analyses

Full Control In addition to
Read/Write
permissions, users
with full control can
n Move methods into
any project that the
user owns or has
Read/Write
permissions on

n Delete methods

In addition to
Read/Write
permissions, users
with full control can
n Move runs into any
project that the user
owns or has
Read/Write
permissions on

n Delete runs

In addition to
Read/Write
permissions, users
with full control can
n Delete analyses

Table 3. Permission levels and access rights, continued
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Rules for Managing User Accounts
Important: By default, ChromLab administrators have Full Control privileges on all
projects and subprojects.

n All users always have Read access to the default Examples project. You can increase
the permission level on the Examples project to Read/Write or Full Control. However,
you cannot remove access to the project. To limit access to specific files, move the files
from the Examples project into another project and assign specific permissions on that
project.

n Users granted Read access to a project can run methods and save the runs into the
project. This enables technicians to review a method and run it without also having
Write access to the project.

n The user admin is the sole owner of data files that are imported before the ChromLab
administrator creates user accounts. This is the only user who can view the imported
data. After user accounts are created, admin can grant appropriate access levels on
existing projects to users who can then view and access data.

By default, the creator of imported data is always admin.

n After the ChromLab administrator creates user accounts, any user who imports data
files owns that data and has full control. That user can grant appropriate access levels
to other users who can then view and access data.
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Instrument Limitations for Read-Only Users

Important: The following only apply to users with Read access. Users with Read/Write
and Full Control access have full access to the features on the NGC instrument.

n Read-only users cannot manually change the settings while a run is in progress.

n Read-only users cannot perform manual operations using the fraction collector and
outlet valve dialog boxes.

n Read-only users cannot clear run fractions or racks using the Fraction Collector
Viewer.

n Read-only users cannot configure trays using the Fraction Collector Viewer.

Assigning Permission Levels on ChromLab Projects
Important: If you upgraded from ChromLab Software 3.1–5.x standard edition to
ChromLab Software 6.1, User Management Edition, you must grant users access to
existing projects. Ensure that you assign the appropriate permission level to each
user.

Note: Only ChromLab administrators or users who have Full Control permission on a
project can assign and change permission levels or remove user access to the project.

You can assign permission levels to groups or to individual users. Users inherit the group’s
permission on projects, however you can increase or decrease a user’s permission on
specific projects. You can also assign permission levels to a subproject or the parent
project. Users and groups inherit the permission of the parent project, however you can
increase or decrease the permission level as necessary.

To assign permission levels on ChromLab projects

1. Start ChromLab Software, User Management Edition as an active user.

2. If you have not already done so, create projects and subprojects to contain ChromLab
methods, runs, and analyses.
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Tip: See the chapter Managing ChromLab Data in the NGC Chromatography and
ChromLab Software User Guide for information about creating and managing
ChromLab projects.

3. Select File > Browse Data to open the Browse Data dialog box.

Projects that you can access appear in the left pane.

4. In the left pane, select the Permissions tab. ChromLab lists the active users in the right
pane.
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Note: ChromLab administrators account have Full Control access to the project.
You cannot remove this permission from ChromLab administrators.

5. (Optional) In the left pane, expand the projects list to display subprojects.

6. Do one of the following:

n To assign access permissions to groups, select Groups in the View by dropdown
list.

n To assign access permissions to users, select Users in the View by dropdown list.

7. Select the user or group you want to assign access to the project.

8. By default, ChromLab assigns permission levels from either the group or parent
project. To assign a specific permission level to the user or group, select Specify
permissions manually and select the permission level from the dropdown list.

Tip: Permission levels are inclusive. If you select Read & Write permission,
ChromLab automatically selects the Read checkbox. Similarly, selecting Full
Control automatically selects the Read and Read & Write checkboxes.
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9. Do one of the following:

n To view the data files in the project, click Exit Permissions in the left pane.

n To close the Browse Data dialog box, click Close.

The permissions are saved to the User Management Edition database.
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Computers to One NGC System

With ChromLab software, multiple ChromLab computers can simultaneously connect to the
same NGC system.

In ChromLab Software, User Management Edition access to the NGC system is granted at
the user and group level. User Management Edition provides three access levels to the
NGC systems. Access levels determine the user’s access rights to the NGC system.

n View — the user can view activity on the NGC system but cannot start runs or make
manual changes

n Control — the user can run and manually modify methods on the NGC system

n Take Control — the user can take control of the NGC system and override another
user's control of an instrument

This is useful in the event that the controlling computer is locked or the user performing
the run is not available and there is an immediate need to stop the instrument.

After creating users and groups, the ChromLab administrator can grant them access to the
NGC systems. Users and groups can have different access levels on each instrument. If the
user belongs to a group, the user’s access level is inherited from the group. If the user
belongs to multiple groups, all of which have different permission levels on an instrument,
the user inherits the highest access level.

For example, user EBrizel belongs to the groups Location_ChAZ and Location_SR. The
group Location_ChAZ has View access to NGC 1, and the group Location_SR has Take
Control to NGC_1. Conversely, group Location_ChAZ has Take Control on NGC_3 while
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Location_SR has View access. As a member of both groups, user EBrizel has Take Control
access on both instruments.

The ChromLab administrator can limit user EBrizel’s access level to either instrument as
necessary.

Rules for Managing Access to NGC Systems

Important: View mode applies only to users or groups connecting to an NGC system
through a ChromLab computer. The NGC system’s touch screen is never in View
mode. All relevant features are available from the touch screen.

n ChromLab administrators have Take Control access to all NGC systems. You cannot
change this access level for these users.

n The first user connecting to an NGC system from a ChromLab computer has full control
of the instrument. The first user’s computer retains control until a user with Take
Control access overrides the instrument.

n In a shared database environment a user can take control any time except during
system calibration or a Point-to-Plumb operation. Unsaved data from manual runs or
current runs are saved to the shared database.

n In a standard environment (one in which each ChromLab computer saves data to its
own database), a user cannot take control if any of the following conditions are true:

o The NGC system has a run in progress

o The system has queued runs pending

o The system has unsaved manual data

o A user is logged into the NGC system
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Accessing ChromLab Features in View and
Take-Control Modes

The access level of the user (View access or Take-Control access) determines which
features on the NGC system are available.

Important: View mode applies only to users connecting to the NGC system through a
ChromLab computer. The NGC system’s touch screen is never in View mode. All
relevant features are available from the touch screen.

The following table lists the features and their availability depending on the user’s access
level.

Feature View Mode Take-Control Mode

Calibration menu item Disabled in System
Control > Tools

Taking control during calibration is
disabled

Point-to-Plumb menu
item

Disabled in System
Control > Tools

Taking control during Point-to-
Plumb operation is disabled

System Settings dialog
box

Opens in read-only mode;
users can view but cannot
change system settings

If the System Settings dialog box is
open and another user takes
control while the first user is trying
to save settings changes, the
system displays a message
notifying the first user that saving
is not permitted because the
control was taken by another user

Table 4. Accessing ChromLab features in View and Take-Control modes
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Feature View Mode Take-Control Mode

Map Fluidic Scheme
menu item

Disabled in System
Control > Tools

If the Map Fluidic Scheme dialog
box is open and another user takes
control while the first user is trying
to save a mapping, the system
displays a message notifying the
first user that saving is not
permitted because the control was
taken by another user

Change Fluidic Scheme
menu item

Disabled in System
Control > Tools

If the Change Fluidic Scheme
dialog box is open and another
user takes control while the first
user is trying to select and apply a
fluidic scheme, the system
displays a message notifying the
first user that selecting is not
permitted because the control was
taken by another user

Manual edit dialog boxes Manual edit dialog boxes
in System Control Manual
mode are disabled

Manual edit dialog boxes close
when another user takes control

Chromatogram legend in
System Control window

Legend can expand but
users cannot edit trace
settings

Legend collapses when another
user takes control

System Control window
toolbar buttons

Save, Clear, Autosave,
and Annotate are disabled

Table 4. Accessing ChromLab features in View and Take-Control modes, continued
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Feature View Mode Take-Control Mode

System Control > Manual
menu items

Disabled

Queuing and executing
runs in System Control
window

Disabled

Scheduling methods and
scout methods

Disabled System checks the status of the
user when scheduling or starting a
run

Table 4. Accessing ChromLab features in View and Take-Control modes, continued

User Guide | 91



Chapter 9 ConnectingMultiple ChromLabComputers to OneNGC System

Assigning Access Levels on NGC Systems
Note: Only administrators can assign and change access levels or remove a user’s
access to NGC systems. Perform this task on the central computer after you create
user and group accounts and before you connect remote computers to the central
computer.

You can assign access levels to groups or to individual users. Users inherit the group’s
access level on each NGC system, however you can increase or decrease a user’s access
level on specific systems as necessary. This procedure explains how to assign access
levels by users and groups, and to set a user’s specific access level on a system.

To assign access levels on NGC systems

1. Start ChromLab and log in as a ChromLab administrator.

2. If connected, disconnect ChromLab from all currently connected NGC systems:

a. Save or clear any unsaved runs on the NGC system.

b. On the Home window, click File > Disconnect System and disconnect from the
currently connected system or systems.

3. Click Connect to System and connect to all target NGC systems.

The names of the connected systems appear in the System Control panel on the
Home window.

4. Click the link to a target system in Connected Systems.

The System Control window appears and displays tabs for each connected system.

5. Click the tab for a specific system and select File > System Settings to open its System
Settings dialog box.
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6. Choose the Instrument Permissions tab.

7. Do one of the following:

n To assign access levels to groups, select Groups in the View by dropdown list.

n To assign access levels to individual users, select Users in the View by dropdown
list.

8. For each user or group you want to provide access to the system, select the
appropriate checkbox.

9. Do one of the following:

n To assign a user specific access levels to a system, proceed to Step 10.

n To close the System Settings dialog box, click OK.
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10. To assign a user specific access levels:

a. Select Users in the View by dropdown list and select the target user.

ChromLab displays details about the user including the groups to which the user
belongs and their access levels.

b. By default, Inherit Permissions from groups is selected. Select Specify specific
user permission level and choose the appropriate permission from the dropdown
list.
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c. Click OK to exit the System Settings dialog box.
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Taking Control of an NGC System
Taking control of an NGC system is useful in the event that the controlling computer is
locked or the user performing a run is not available and there is an immediate need to stop
the instrument.

Note: Only users with the Take Control access level can perform this task. Take
Control is disabled during system calibration or Point-to-Plumb actions.

To take control of an NGC system

1. If you have not already done so, connect to the target NGC system as a user with Take
Control access level.

2. Select File > Take Control.

If successful, ChromLab displays a message informing you that you have control of the
system. ChromLab displays a relevant message to the user who lost control.
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Appendix A Troubleshooting Shared
Database Connection Issues

This appendix lists potential causes and suggested solutions for resolving connection
issues when remote ChromLab computers or NGC instruments cannot access the shared
database.

Important: Bio-Rad strongly recommends that you regularly back up the shared
ChromLab database and save the backup file in a safe location. For more information
about backing up the ChromLab database, see the chapter Database Maintenance in
the NGC Chromatography Systems and ChromLab Software User Guide.

Possible Causes for Shared Database Connection
Issues

Table 5 lists possible causes and solutions for issues connecting to the shared ChromLab
database.
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Possible Cause Possible Solution

Database server settings have
changed

n Change the database location properties on the central
computer and then reconnect each remote computer.

See Changing the Location Parameters of Shared
Database on page 100.

NGC database service is not
started

n Restart the database service on the central computer.

See Restarting the NGC Database Service on page 101.

NGC database service fails to
start

n Uninstall and then reinstall ChromLab on the central
computer.

See the NGC Chromatography Systems and ChromLab
Software Installation Guide for specific information.

n Uninstall SQL Server on the central computer. Then
reinstall ChromLab on the central computer.

See Uninstalling Microsoft SQL Server on the Central
ChromLab Computer on page 102.

n Contact Bio-Rad Technical Support for assistance.

Network connection fails n Your site’s DNS server might be down. If you
connected to the central computer using its computer
name, change the connection parameters to use its IP
address.

See Changing the Connection Parameters to the Central
Computer on page 104.

Table 5. Possible causes and solutions for shared database connection issues
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Possible Cause Possible Solution

n Your site’s firewall or antivirus tools require specific
ports for network communication. SQL Server requires
port 1433, which might not be allowed in your firewall
environment.

See Appendix D, Firewall Configuration in the NGC
Chromatography Systems and ChromLab Software
Installation Guide for specific information.

See Article 287932 on Microsoft’s Knowledge Base site
for more information:
http://support.microsoft.com/kb/287932

n You removed ChromLab software from the central
computer and must manually add specific firewall rules.

See Manually Adding Inbound Firewall Rules on page
105.

n The shared database resides on another subnet, which
is not accessible from a remote ChromLab computer or
an NGC system. Verify that the central computer can
ping the remote ChromLab computer or NGC system
using ping command line.

See Verifying that All NGC Systems Can Reach the
Central Computer on page 23.

n Verify that routing between subnets or virtual local area
network (VLAN) is configured properly.

Contact your system or network administrator for
assistance.

Table 5. Possible causes and solutions for shared database connection issues,
continued
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Solutions for Shared Database Connection Issues
This section details possible solutions if remote ChromLab computers or NGC systems
cannot connect to the shared ChromLab database.

Changing the Location Parameters of Shared Database
If you moved the central ChromLab database to another computer, or changed the name of
the computer on which it is located, you must change the connection location properties.
You perform this task on the central computer through ChromLab Administration. Then you
can reconnect the remote computers to the central computer.

To change the location parameters of the central computer

1. Determine the computer’s name:

a. On the central computer, right-click the computer’s desktop icon and select
Properties.

The System Information screen appears.

b. Locate and note the computer name and full computer name.

c. Close the System Information screen.

2. Determine the computer’s IP address:

a. Open a command prompt window.

b. At the command prompt, type ipconfig.

c. Note the information on the line IPv4 Address.

Note: Ensure that the computer’s IP address is static.

d. Close the command prompt window.
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3. Launch ChromLab Administration.

Note: If ChromLab Administration fails to connect, the Change Database Server
dialog box appears. Use this dialog box to

n Change the server address

n Specify the new settings

n Provide the administrator’s login credentials

n Connect to the central computer with the new settings you noted in Steps 1–2.

4. Exit ChromLab Administration.

5. On each remote computer, start ChromLab Administration and reconnect to the central
computer.

For more information, see Chapter 5, Connecting Remote Computers to the Central
Computer.

Restarting the NGC Database Service
Important: Ensure that ChromLab is not running before you restart the NGC database
service.

To restart the NGC database service

1. On the central computer’s desktop, right-click the computer’s desktop icon and select
Manage.

The Computer Management dialog box appears.

2. In the Computer Management dialog box, expand Services and Applications in the left
pane and select Services.

A list of services appears in the right pane.
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3. In the list of services, locate and right-click SQL Server (NGC).

4. Select Start in the list of actions that appears.

5. Close the Computer Management dialog box.

Uninstalling Microsoft SQL Server on the Central
ChromLab Computer
Important: You might need to uninstall SQL Server if it is corrupted. Bio-Rad strongly
recommends that you back up all SQL Server databases you might have, close all
applications that use SQL Server, and uninstall the applications before continuing.

To uninstall Microsoft SQL Server

1. On the central computer, uninstall ChromLab first and then uninstall Microsoft
SQL Server:

a. Select Start > Control Panel > Programs and Features.

The Uninstall or change a program window appears.

b. In the list of installed programs, locate and select ChromLab.
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c. Click Uninstall/Change to uninstall ChromLab.

d. In the list of installed programs, locate and uninstall Microsoft SQL Server.

2. When the uninstallation is complete, locate and rename the NGC database folder.

This folder is located at C:\ProgramData\Bio-Rad\NGC\Database. Rename the folder
to Database_old.

3. Reinstall ChromLab software on the central computer.

Tip: The ChromLab software installer detects that SQL Server is not installed and
installs the application.

4. Activate User Management Edition and designate the new database as the shared
database.

For more information, see Activating User Management Edition on the Central
Computer on page 29.

5. If you regularly backed up the original database, restore the data into the new
database.

6. Do one of the following:

n If you changed the name of the ChromLab central computer or its IP address, go
to Step 7.

n If you retained the computer’s name and IP address, go to Step 9.

7. On all remote computers, start ChromLab Administration and select the Database
Location tab.

8. Provide the required information and click Connect.

9. Start ChromLab on the remote computers and verify connection to the shared
database.
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Changing the Connection Parameters to the Central
Computer
If you selected the central computer’s name as the connection parameter when you
connected to the shared database, you might need to change the connection parameter to
its IP address.

Tip: Skip Step 1 if you know the IP address of the central computer.

To change the connection parameters to the central computer

1. Determine the computer’s IP address:

a. Open a command prompt window.

b. At the command prompt, type ipconfig.

c. Note the information on the line IPv4 Address.

Note: Ensure that the computer’s IP address is static.

For more information about locating the IP address of a computer, see your
system or network administrator.

d. Close the command prompt window.

2. On each remote computer, open a command prompt window and ping the central
computer. For example:

> ping <Central_ChromLab_computer_IP_Address>

The central computer responds to the ping request if it is available on the network.

Note: See your system or network administrator if the central computer fails to
respond to the ping request.

3. On each remote computer, start ChromLab Administration and select the Database
Location tab.
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4. In the Remote Shared Database dropdown list, select the IP address of the central
computer.

5. Click Connect.

6. Start ChromLab and verify the connection to the shared database.

Manually Adding Inbound Firewall Rules
Important: If you uninstall ChromLab from the central computer, you must create
custom inbound firewall rules in order for the SQL Browser and SQL Server services to
receive data from the network. Contact your system or network administrator or
Bio-Rad Technical Support for assistance.

n Bio-Rad NGC SQLServer NG

Enables communication to the NGC database

n Bio-Rad NGC SQLServer Browser

Publishes data about SQL Server and is used during initial connection to the database

Table 6 lists the required firewall settings for these rules. Ensure that your firewall tool
follows these rules for the NGC database on the central ChromLab computer or server.

Rule Program Protocol Local Port
Remote
Port

Bio-Rad NGC SQLServer
NG

Any Any Any Any

Bio-Rad NGC SQLServer
Browser

Any Any Any Any

Table 6. Firewall inbound rules for the ChromLab database

Tip: See Appendix D, Firewall Configuration in the NGC Chromatography Systems
and ChromLab Software Installation Guide for more information.
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This appendix comprises checklists that you can use to prepare your site for and set up the
shared ChromLab database.

Preparing Your Site
Use this checklist to prepare the computers to use the shared ChromLab database.

Note: Bio-Rad recommends that you set up the shared database on a new computer
and connect your existing ChromLab computers to the new database.

Task For Details

1. Determine the computer to host the
shared database.

2. Verify the site requirements for the
central computer.

See the NGC Chromatography Systems and
ChromLab Software Installation Guide.

3. Verify the central computer meets the
system requirements.

See System Requirements on page 13.

Table 7. Site preparation checklist
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Task For Details

4. Install ChromLab software on all
computers.

See the NGC Chromatography Systems and
ChromLab Software Installation Guide.

Note: You can upgrade ChromLab
software standard or User Management
Edition from version 3.x or higher to
version 6.1. If you are running an earlier
version of ChromLab software, you must
first upgrade to 3.x before you can
upgrade to ChromLab 6.1.

5. Prepare the ChromLab central
computer and NGC systems.

See Preparing the Central Computer and
NGC Systems on page 15.

6. Prepare the remote computers. See Connecting Remote Computers to the
Central Computer on page 37.

Table 7. Site preparation checklist, continued
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Setting Up the Shared Environment
Use this checklist to set up the shared ChromLab database and connect to it from the
remote computers.

Task Computer For Details

1. Verify that ChromLab 6.1 is
installed.

All computers See the NGC
Chromatography
Systems and ChromLab
Software Installation
Guide for details.

2. (Optional) Restore NGC data to
the shared database.

Central Computer See Backing Up and
Restoring ChromLab Data
to the Central Computer
on page 17.

3. Create an NGC database backup
folder.

All computers See Creating an NGC
Database Backup Folder
on page 39.

4. Change the default admin
password in ChromLab
Administration.

All computers See Changing the
ChromLab Default
Password on page 41.

5. Activate User Management
Edition and designate the shared
database.

Central computer See Activating User
Management Edition on
the Central Computer on
page 25.

6. Create ChromLab users and
groups

Central computer See Next Steps on page
33.

Table 8. Setting up the shared environment
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Task Computer For Details

7. (Optional) Export existing data
from all computers.

Remote computers See Exporting Existing
ChromLab Data on page
40.

8. Activate User Management
Edition and connect to the shared
database.

Remote computers See Connecting Remote
Computers to the Central
Computer on page 37.

9. (Optional) Import existing data to
the shared database.

Central computer See Importing Existing
ChromLab Data on page
46.

Table 8. Setting up the shared environment, continued
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